<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="">

<title>Clean The Beaver &#8211; The Steve Dahl Network</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Steve Dahl Network &raquo; Feed" href="http://www.dahl.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Steve Dahl Network &raquo; Comments Feed" href="http://www.dahl.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Steve Dahl Network &raquo; Clean The Beaver Comments Feed" href="http://www.dahl.com/kevin-matthews/kevins-blog/clean-the-beaver/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.dahl.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-polls-css'  href='http://www.dahl.com/wp-content/themes/innov8-podcast-network/polls-css.css?ver=2.73.3' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #3265C1;
	border: 1px solid #3265C1;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C300%2C500%2C600%2C700%2C800&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='normalize-css'  href='http://www.dahl.com/wp-content/themes/innov8-podcast-network/css/normalize.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='http://www.dahl.com/wp-content/themes/innov8-podcast-network/css/bootstrap.css?ver=3.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://www.dahl.com/wp-content/themes/innov8-podcast-network/css/font-awesome.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='dialogcss-css'  href='http://www.dahl.com/wp-content/themes/innov8-podcast-network/css/jquery-ui.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='innov8-podcast-network-style-css'  href='http://www.dahl.com/wp-content/themes/innov8-podcast-network/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-playlists-gallery-css'  href='http://www.dahl.com/wp-content/plugins/youtube-playlists-gallery/styles.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery.magnific-popup-css'  href='http://www.dahl.com/wp-content/plugins/youtube-playlists-gallery/magnific-popup.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-galleries-0-css'  href='http://www.dahl.com/wp-content/cycloneslider/galleries/style.css?ver=2.12.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-home-0-css'  href='http://www.dahl.com/wp-content/cycloneslider/home/style.css?ver=2.12.4' type='text/css' media='all' />
<script type='text/javascript' src='http://www.dahl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simple_favorites = {"ajaxurl":"http:\/\/www.dahl.com\/wp-admin\/admin-ajax.php","favorite":"Add to Favorites","favorited":"Favorited","includecount":"","indicate_loading":"","loading_text":"Loading","loading_image":"","loading_image_active":"","loading_image_preload":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/favorites/assets/js/simple-favorites.min.js?ver=1.2.3'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/themes/innov8-podcast-network/js/jquery-ui.js?ver=4.7.2'></script>
<link rel='https://api.w.org/' href='http://www.dahl.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.dahl.com/xmlrpc.php?rsd" />
<link rel='prev' title='Pies for Mom' href='http://www.dahl.com/kevin-matthews/kevins-blog/pies-for-mom/' />
<meta name="generator" content="WordPress 4.7.2" />
<meta name="generator" content="Seriously Simple Podcasting 1.15.1" />
<link rel="canonical" href="http://www.dahl.com/kevin-matthews/kevins-blog/clean-the-beaver/" />
<link rel='shortlink' href='http://www.dahl.com/?p=7129' />
<link rel="alternate" type="application/json+oembed" href="http://www.dahl.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.dahl.com%2Fkevin-matthews%2Fkevins-blog%2Fclean-the-beaver%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.dahl.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.dahl.com%2Fkevin-matthews%2Fkevins-blog%2Fclean-the-beaver%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.17.1 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-2 { width:100%; max-width:728px; height:100%; max-height:90px; margin: 0 auto; }
	.g-3 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="http://www.dahl.com/feed/podcast" />

<!-- <meta name="vfb" version="2.9.2" /> -->
<style id="custom-theme">.mainContent .content .block.hpContent .box-3 .name:before { background: #3265c1;}.mainContent .content .block.hpContent .box-4 .name:before { background: #e3912b;}.mainContent .content .block.hpContent .box-5 .name:before { background: #f65f18;}.mainContent .content .block.hpContent .box-6 .name:before { background: #d21918;}.mainContent .content .block.hpContent .box-7 .name:before { background: #39b2d1;}.mainContent .content .block.hpContent .box-8 .name:before { background: #9666c9;}</style><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-78113892-1', 'auto');
  ga('send', 'pageview');

</script>
</head>
<body class="post-template-default single single-post postid-7129 single-format-standard term-4 group-blog" style="background-image: url(http://dahl.com/wp-content/uploads/2015/06/bg-kevinmatthews.jpg)">
<div class="container-fluid">
	<header>
		<div class="header">
			<nav class="navbar navbar-default">
				<div class="container-fluid">
					<div class="navbar-collapse">
						<div class="leftwrap">
						<ul id="menu-primary" class="nav navbar-nav"><li id="menu-item-35" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-35 dropdown"><a title="Shows" href="#" data-toggle="dropdown" role="button" class="dropdown-toggle dd" aria-expanded="false">Shows</a></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-55"><a title="The Steve Dahl Show" href="http://www.dahl.com/steve-dahl-show/">The Steve Dahl Show</a></a></li>
	<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-54"><a title="Kevin Matthews Show" href="http://www.dahl.com/kevin-matthews/">Kevin Matthews Show</a></a></li>
	<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-60"><a title="Matt &amp; Brendan Show" href="http://www.dahl.com/matt-and-brendan/">Matt &#038; Brendan Show</a></a></li>
	<li id="menu-item-59" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-59"><a title="Hindsight with DVK" href="http://www.dahl.com/hindsight/">Hindsight with DVK</a></a></li>
	<li id="menu-item-57" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-57"><a title="Bob &amp; Ron&#039;s Record Club" href="http://www.dahl.com/bob-and-ron/">Bob &#038; Ron&#8217;s Record Club</a></a></li>
	<li id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-58"><a title="Descent Into The Archives" href="http://www.dahl.com/descent-into-the-archives/">Descent Into The Archives</a></a></li>
</ul>
</li>
<li id="menu-item-102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-102 dropdown"><a title="About" href="#" data-toggle="dropdown" role="button" class="dropdown-toggle dd" aria-expanded="false">About</a></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-34" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34"><a title="About Steve Dahl" href="http://www.dahl.com/about/about-steve-dahl/">About Steve Dahl</a></a></li>
	<li id="menu-item-33" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33"><a title="About Kevin Matthews" href="http://www.dahl.com/about/kevin-matthews/">About Kevin Matthews</a></a></li>
	<li id="menu-item-32" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32"><a title="Matt &#038; Brendan" href="http://www.dahl.com/about/matt-brendan/">Matt &#038; Brendan</a></a></li>
	<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31"><a title="Daniel Van Kirk" href="http://www.dahl.com/about/daniel-van-kirk/">Daniel Van Kirk</a></a></li>
	<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a title="About Bob &amp; Ron" href="http://www.dahl.com/about/bob-ron/">About Bob &#038; Ron</a></a></li>
	<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a title="Descent Into The Archives" href="http://www.dahl.com/about/descent-into-the-archives/">Descent Into The Archives</a></a></li>
</ul>
</li>
<li id="menu-item-42" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42 dropdown"><a title="Media Center" href="#" data-toggle="dropdown" role="button" class="dropdown-toggle dd" aria-expanded="false">Media Center</a></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172"><a title="Videos" href="http://www.dahl.com/media/">Videos</a></a></li>
	<li id="menu-item-313" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-313"><a title="Blogs" href="http://www.dahl.com/blogs/">Blogs</a></a></li>
</ul>
</li>
<li id="menu-item-5051" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5051"><a title="Store" href="http://www.dahl.com/the-store/">Store</a></a></li>
<li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a title="Our Network" href="http://www.dahl.com/about/">Our Network</a></a></li>
</ul>						</div>
						<div class="rightwrap">
							<ul class="nav navbar-nav navbar-right">
								<li class="logo"><a href="/"><img src="/wp-content/themes/innov8-podcast-network/img/steve-dahl-network-logo.png" alt="Steve Dahl"></a></li>
								<li class="menu"><a href="#"><i class="fa-bars"></i></a></li>
								<li class="home"><a href="/"><i class="fa-home"></i></a></li>
																<li class="info"><a href="http://www.dahl.com/support/"><i class="fa-info"></i></a></li>
								<li class="favs addthis_toolbox"><a class="addthis_button_compact addthis_button" href="#"><i class="fa-thumbs-up"></i></a></li>
								<li class="search"><a href="#"><i class="fa-search"></i></a></li>
																	<li class="login"><a href="http://www.dahl.com/login/">Login</a></li>
															  </ul>
							
		<ul class="dropmenu">
		
			<li>
						<a href="#" class="menu-item dd">Shows</a>

		
		
		
		
		
						<ul class="dropdown">
							<li>
					<a href="http://www.dahl.com/steve-dahl-show/">The Steve Dahl Show</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/kevin-matthews/">Kevin Matthews</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/matt-and-brendan/">Matt & Brendan</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/hindsight/">Hindsight with Daniel Van Kirk</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/bob-and-ron/">Bob & Ron's Record Club</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/descent-into-the-archives/">Descent Into The Archives</a>
				</li>
							</ul>
			
		
				</li>                        
			
		
			<li>
						<a href="#" class="menu-item dd">About</a>

		
		
		
		
		
						<ul class="dropdown">
							<li>
					<a href="http://www.dahl.com/about/">About SDN</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/about/about-steve-dahl/">About Steve Dahl</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/about/kevin-matthews/">About Kevin Mathews</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/about/matt-brendan/">Matt &#038; Brendan</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/about/daniel-van-kirk/">About Daniel Van Kirk</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/about/bob-ron/">About Bob & Ron</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/about/descent-into-the-archives/">Descent Into The Archives</a>
				</li>
							</ul>
			
		
				</li>                        
			
		
			<li>
						<a href="#" class="menu-item dd">Media Center</a>

		
		
		
		
		
						<ul class="dropdown">
							<li>
					<a href="http://www.dahl.com/media/">Videos</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/photos/">Photo Galleries</a>
				</li>
				
		
		
		
		
							<li>
					<a href="http://www.dahl.com/blogs/">Blogs</a>
				</li>
							</ul>
			
		
				</li>                        
			
		
			<li>
						<a href="http://www.dahl.com/the-store/" class="menu-item">Store</a>

		
		
				</li>   	
		
			</ul>
 				      </div>
						<div class="search-bar">
							<input type="text" placeholder="Search..." class="search text"><input type="text" class="submit" value="">
						  </div>
					</div><!-- /.navbar-collapse -->
				</div><!-- /.container-fluid -->
			</nav><!-- #site-navigation -->
			<div class="container-fluid">
				<div class="row">
					<div class="networkWrap">
	<div class="network"><a href="#">The Steve Dahl Network</a></div>
	<div id="networkDrop">
		<div  style="width: 1120px;" class="micContain">
			<div class="col col-md-1 col-sm-1 col-xs-1"><a href="/"><img src="/wp-content/themes/innov8-podcast-network/img/steve-dahl-network-logo.png" alt="Steve Dahl"></a></div>
						<div class="col col-md-1 col-sm-1 col-xs-1"><a href="http://www.dahl.com/steve-dahl-show/"><img src="http://dahl.com/wp-content/uploads/2015/06/logo-steve-dahl.png" /></a></div>	
						<div class="col col-md-1 col-sm-1 col-xs-1"><a href="http://www.dahl.com/kevin-matthews/"><img src="http://dahl.com/wp-content/uploads/2015/06/logo-kevin-matthews.png" /></a></div>	
						<div class="col col-md-1 col-sm-1 col-xs-1"><a href="http://www.dahl.com/matt-and-brendan/"><img src="http://dahl.com/wp-content/uploads/2015/06/logo-matt-and-brendan.png" /></a></div>	
						<div class="col col-md-1 col-sm-1 col-xs-1"><a href="http://www.dahl.com/hindsight/"><img src="http://dahl.com/wp-content/uploads/2015/06/logo-hingsight-vankirk.png" /></a></div>	
						<div class="col col-md-1 col-sm-1 col-xs-1"><a href="http://www.dahl.com/bob-and-ron/"><img src="http://dahl.com/wp-content/uploads/2015/05/logo-bob-and-ron.png" /></a></div>	
						<div class="col col-md-1 col-sm-1 col-xs-1"><a href="http://www.dahl.com/descent-into-the-archives/"><img src="http://dahl.com/wp-content/uploads/2015/05/logo-descent-into-archives1.png" /></a></div>	
					</div>
	</div>
</div>				</div>
			</div>

			<div class="container-fluid shows">
				
<div class="row">
	<div class="col-md-2 col-sm-2 col-xs-2">
				<div class="logo"><a href="/"><img src="http://dahl.com/wp-content/uploads/2015/06/logo-kevin-matthews.png" alt=""></a></div>
	</div>
	<div class="col-md-5 col-sm-5 col-xs-12 latest">
		<h3>The Latest Shows</h3>
		<ul>
							<li><a href="http://www.dahl.com/kevin-matthews/podcast/the-kevin-matthews-show-may-12-2017/"></a><span class="date">May 12, 2017</span></li>
							<li><a href="http://www.dahl.com/kevin-matthews/podcast/the-kevin-matthews-show-may-5-2017/"></a><span class="date">May 05, 2017</span></li>
					</ul>
		<div class="next">
			<span class="airs">Next Show Airs: </span>
			<span class="date">May 19, 2017</span>
		</div>
	</div>
	<div class="col-md-5 col-sm-5 col-xs-12 connect">
		<h3>Connect</h3>
		<ul>
							<li><a class="fb" target="_blank" href="https://www.facebook.com/whatareyougoofy?fref=ts"></a></li>
							<li><a class="tw" target="_blank" href="https://twitter.com/whatareyougoofy"></a></li>
										<li><a class="rss" href="/feed/podcast/sample/kevin-matthews"></a></li>
						
							<li><a class="ph" href="#"></a></li>
					</ul>
				<div id="phone-collapse">tel: 312-380-9784</div>
					<div class="favs"><a href="/login/">My Favorites</a></div>
			</div>
</div>
			</div>
		</div>
	</header>
	<div class="row mainContent">
		<section>
			<div class="col col-md-8 col-sm-8 col-xs-12 content">
						
				<div class="mainTitle">
		<h1>Clean The Beaver</h1>	</div><!-- .entry-header -->

	<div class="block">
		<div id=":180" class="ii gt adP adO">
<div id=":181" class="a3s aXjCH m15c16f8c73845ff2">
<div dir="ltr">
<div><img class="alignnone size-medium wp-image-7131" src="https://www.dahl.com/wp-content/uploads/2017/05/Blogkev-187x140.jpg" alt="" width="187" height="140" data-id="7131" srcset="http://www.dahl.com/wp-content/uploads/2017/05/Blogkev-187x140.jpg 187w, http://www.dahl.com/wp-content/uploads/2017/05/Blogkev-768x575.jpg 768w, http://www.dahl.com/wp-content/uploads/2017/05/Blogkev-1024x767.jpg 1024w" sizes="(max-width: 187px) 100vw, 187px" /></div>
<div>Hey Kevheads, It&#8217;s Wayne from the Beaver Island Casino. I don&#8217;t stutter anymore. The shock therapy and  Frontal Lobotomy worked.</div>
<div></div>
<div>We have spring cleaning going on here at the Casino. Nothing beats a clean Beaver.</div>
<div>The Chicago Cubs are back on track after hitting 4 home-runs last night and Manager Joe Maddon got his 1,000th Victory as manager.</div>
<div></div>
<div>In the NBA&#8230;The Golden State Warriors are on fire. They have won 10 straight games as they took down the San Antonio Spurs 136 to 100. They will win it all.</div>
<div></div>
<div>The National Hockey League, who cares? The Pittsburgh Penguins will repeat. Put the mortgage on it.</div>
<div>The Chicago White Sox lost a nail biter last night in 11 innings to the Angels. They now sit 3 games back in the division.</div>
<div></div>
<div>Happy 61st birthday to Bob Saget. Welcome back Steve Dahl. It&#8217;s great to hear you in the air and on the Steve Dahl Network again.</div>
<div></div>
<div>Give us a call on the Kevin Matthew&#8217;s Voicemail <a href="tel:(312)%20380-9784" target="_blank">(312)380-9784</a>, Tell us who you are, where you are and tell us what&#8217;s on your mind.</div>
<div></div>
<div>Tune in to <a href="http://dahl.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://dahl.com&amp;source=gmail&amp;ust=1495131213804000&amp;usg=AFQjCNHCgRsy87k_L4ZnPRRUA2gTOI1xHA">dahl.com</a> <span class="aBn" tabindex="0" data-term="goog_605098909"><span class="aQJ">Friday</span></span> for an all new Kevin Matthew&#8217;s Show. We have a special Kevhead on the show this week.</div>
<div>It&#8217;s time for my dear wife Matilda to give me my daily enema so I have to go&#8230;.</div>
<div></div>
<div>Thank you nurse Janet Joliet Dahl for your loving care for Steve. Thank you Dag and Brendan for keeping the show rolling. Most of all thank you Mallory and Don for helping to get this Blog out to the Kevheads every week.</div>
<div></div>
<div>Join us on facebook at Kevhead Row and tell your friends this is where Kevin lives. Right here at <a href="http://dahl.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://dahl.com&amp;source=gmail&amp;ust=1495131213804000&amp;usg=AFQjCNHCgRsy87k_L4ZnPRRUA2gTOI1xHA">dahl.com</a></div>
<div>______________________________<wbr />______________________________<wbr />_____</div>
<div>Until next week,</div>
<div>Wayne Stutterman</div>
<div>(Beaver Island Casino)</div>
<div>(Pit-Boss)</div>
<div>(former stuttering prick)</div>
<div class="yj6qo"></div>
</div>
</div>
</div>
<div id=":12s" class="hq gt"></div>
	</div><!-- .entry-content -->

					</div>
		</section>
		
<aside>
	<div class="col col-md-4 col-sm-4 col-xs-12 sidenav">
	<div class="sidenavHead"><h2>Categories</h2></div>
<ul id="categories-sub-widget">

	<li>
		<a class="collapsed parent-collapsible" href="#collapse-97" aria-controls="collapse-97" data-toggle="collapse">The Steve Dahl Show</a>
				<ul id="collapse-97" class="collapse">
						<li><a href="http://www.dahl.com/steve-dahl-show/dagblag/">Dagblag</a></li>
						<li><a href="http://www.dahl.com/steve-dahl-show/tidbits/">Tidbits</a></li>
						<li><a href="http://www.dahl.com/steve-dahl-show/media/">Media</a></li>
						<li><a href="http://www.dahl.com/steve-dahl-show/steve-s-blog/">Steve's Blog</a></li>
						<li><a href="http://www.dahl.com/steve-dahl-show/janet-s-time-wasters/">Janet's Time Wasters</a></li>
						<li><a href="http://www.dahl.com/steve-dahl-show/janet-s-blog/">janet's dahl, et al.</a></li>
					</ul>
				
	</li>	
	<li>
		<a class="collapsed parent-collapsible" href="#collapse-103" aria-controls="collapse-103" data-toggle="collapse">Kevin Matthews</a>
				<ul id="collapse-103" class="collapse">
						<li><a href="http://www.dahl.com/kevin-matthews/jim-shorts/">Jim Shorts</a></li>
						<li><a href="http://www.dahl.com/kevin-matthews/kevins-blog/">Kev's Blog</a></li>
					</ul>
				
	</li>	
	<li>
		<a class="collapsed parent-collapsible" href="#collapse-106" aria-controls="collapse-106" data-toggle="collapse">Matt &amp; Brendan</a>
				<ul id="collapse-106" class="collapse">
						<li><a href="http://www.dahl.com/matt-and-brendan/matt-brendan-s-blog/">Matt &amp; Brendan's Blog</a></li>
					</ul>
				
	</li>	
	<li>
		<a class="collapsed parent-collapsible" href="#collapse-108" aria-controls="collapse-108" data-toggle="collapse">Hindsight W/Daniel Van Kirk</a>
				<ul id="collapse-108" class="collapse">
						<li><a href="http://www.dahl.com/hindsight/hindsight-with-daniel-van-kirk/">Hindsight: Daniel's Blog</a></li>
					</ul>
				
	</li>	
	<li>
		<a class="collapsed parent-collapsible" href="#collapse-110" aria-controls="collapse-110" data-toggle="collapse">Bob &amp; Ron</a>
				<ul id="collapse-110" class="collapse">
						<li><a href="http://www.dahl.com/bob-and-ron/ron-s-blog/">Ron's Blog</a></li>
					</ul>
				
	</li>	

</ul>
		<div id=recent-posts-2" class="widget widget_recent_entries">		<div class="sidenavHead"><h2>Recent Posts</h2></div>		<ul>
					<li>
				<a href="http://www.dahl.com/kevin-matthews/kevins-blog/clean-the-beaver/">Clean The Beaver</a>
						</li>
					<li>
				<a href="http://www.dahl.com/kevin-matthews/kevins-blog/pies-for-mom/">Pies for Mom</a>
						</li>
					<li>
				<a href="http://www.dahl.com/kevin-matthews/kevins-blog/wheres-the-beef/">Where&#8217;s the Beef?!</a>
						</li>
					<li>
				<a href="http://www.dahl.com/kevin-matthews/kevins-blog/bye-bye-april/">Bye Bye April</a>
						</li>
					<li>
				<a href="http://www.dahl.com/kevin-matthews/kevins-blog/waynes-gone/">Wayne&#8217;s Gone</a>
						</li>
				</ul>
		</div>				<div class="rotate-ads" id="sidebar-ads">
			<div class="g g-1"><div class="g-dyn a-13 c-1"><a class="gofollow" data-track="MTMsMSwxLDYw" href="http://www.perldavid.com/"><img src="https://www.dahl.com/wp-content/uploads/2016/06/Perl-logo-orange2.gif" /></a></div><div class="g-dyn a-7 c-2"><a class="gofollow" data-track="NywxLDEsNjA=" href="http://fabflowers.com/"><img src="http://dahl.com/wp-content/uploads/2015/10/Fabbrinis-300x250.png" /></a></div><div class="g-dyn a-5 c-3"><a class="gofollow" data-track="NSwxLDEsNjA=" href="http://www.gregghelfer.com/"><img src="/wp-content/uploads/2015/09/Helfer1-300x250.png" /></a></div><div class="g-dyn a-12 c-4"><a class="gofollow" data-track="MTIsMSwxLDYw" href="http://www.thelittleguys.com/"><img src="https://www.dahl.com/wp-content/uploads/2016/06/lil_guys_logo_Blue.gif" /></a></div><div class="g-dyn a-16 c-5"><iframe src="//z-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetAdHtml&ID=OneJS&OneJS=1&banner_type=setandforget&campaigns=holsetforget2016&placement=assoc_banner_placement_default&region=US&marketplace=amazon&ad_type=banner&height=250&width=300&f=ifr&linkID=36e4f237ffa1cdf79e33ced00a9544c6&t=thestedahpodn-20&tracking_id=thestedahpodn-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div><div class="g-dyn a-10 c-6"><a class="gofollow" data-track="MTAsMSwxLDYw" href="http://www.hollandermoving.com/"><img src="http://dahl.com/wp-content/uploads/2015/10/HollanderMoving-300x250.jpg" /></a></div></div>		</div>
				</div>
</aside><!-- #secondary -->
	</div><!-- #primary -->

<div id="bottom-ads" class="rotate-ads row">
	<div class="g g-2"><div class="g-dyn a-15 c-1"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=48&l=ur1&category=electronics&f=ifr&linkID=dc6914ce966d7a4c0198cc58d5c39a9f&t=thestedahpodn-20&tracking_id=thestedahpodn-20" width="728" height="90" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div></div></div>
	<div class="row subscribe">
	<div class="infoHead">
		<h3 class="title">NEWSLETTER</h3>
	</div>
	<div class="infoContent">
		<p>Sign up for the Steve Dahl Network Newsletter. We promise to keep you up to date, but not bug you!</p>
	</div>
	<div class="infoLink">
		<a href="/newsletter/" class="signup">SIGN UP</a>
	</div>
</div>
	</div><!-- #content -->

	<footer>
		<div class="footer">
			<div class="container-fluid">
				<div class="row footerTop">
				
						<div class="col col-md-2 col-sm-6 col-xs-12 show">
						<h3 class="footer-title">Shows</h3>

					
					
					
            
					
												<ul class="footer-list">
													<li class="footer-link">
								<a href="http://www.dahl.com/steve-dahl-show/">The Steve Dahl Show</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/kevin-matthews/">The Kevin Matthews Show</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/matt-and-brendan/">Matt & Brendan</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/hindsight/">Hindsight</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/bob-and-ron/">Bob & Ron</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/descent-into-the-archives/">Descent Into The Archives</a>
							</li>
													</ul>
						
					
										</div>
						
            
						<div class="col col-md-2 col-sm-6 col-xs-12 media">
						<h3 class="footer-title">Media Center</h3>

					
					
					
            
					
												<ul class="footer-list">
													<li class="footer-link">
								<a href="http://www.dahl.com/media/">Videos</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/blogs/">Blogs</a>
							</li>
													</ul>
						
					
										</div>
						
            
						<div class="col col-md-2 col-sm-6 col-xs-12 sub">
						<h3 class="footer-title">Subscription</h3>

					
					
					
            
					
												<ul class="footer-list">
													<li class="footer-link">
								<a href="http://www.dahl.com/gift-subscription/">Gifts</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/benefits/">Benefits</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/members/my-profile/">My Account</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/newsletter/">Newsletter</a>
							</li>
													</ul>
						
					
										</div>
						
            
						<div class="col col-md-2 col-sm-6 col-xs-12 more">
						<h3 class="footer-title">More</h3>

					
					
					
            
					
												<ul class="footer-list">
													<li class="footer-link">
								<a href="http://www.dahl.com/about/about-steve-dahl/">About SDN</a>
							</li>
							
					
					
            
					
													<li class="footer-link">
								<a href="http://www.dahl.com/the-store/">The Store</a>
							</li>
														</ul>
							
					
										</div>
					
            				<div class="col col-md-2 col-sm-12 col-xs-12 dlink">
	            	<a href="https://itunes.apple.com/app/the-steve-dahl-show/id453218711?mt=8"><img class="app-img" src="/wp-content/uploads/2015/07/steve-dahl-podcast-app.png"></a>

	            </div>
				</div>
			</div>

			<div class="footerBtm">
				<div class="container-fluid">
					<div class="row">
						<div class="col col-md-12 col-sm-12 col-xs-12">
							<div class="copyright">&copy; 2017 The Steve Dahl Network.  All Rights Reserved.</div>
							<div class="credits">&nbsp;</div>
							<div class="footlinks">
								<ul>
									<li><a href="/site-map/">Site Map</a></li>
									<li><a href="/terms-conditions/">Terms &amp; Conditions</a></li>
								</ul>
							</div>
						</div>
					</div>
				</div>
			</div>
		</div>
	</footer><!-- #colophon -->

<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/www.dahl.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.dahl.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.dahl.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.3'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/themes/innov8-podcast-network/js/bootstrap.js?ver=3.3.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/themes/innov8-podcast-network/js/main.js?ver=3.3.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.min.js?ver=2.12.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.swipe.min.js?ver=2.12.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.tile.min.js?ver=2.12.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/cycloneslider/galleries/script.js?ver=2.12.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/cyclone-slider-2/js/client.js?ver=2.12.4'></script>
<script type='text/javascript' src='http://www.dahl.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var icegram_pre_data = {"ajax_url":"http:\/\/www.dahl.com\/wp-admin\/admin-ajax.php","post_obj":{"is_home":false,"page_id":7129,"action":"display_messages","shortcodes":[],"cache_compatibility":"no","device":"laptop"}};
var icegram_data = {"messages":[{"post_title":"Get Access to ALL SDN Podcasts!","type":"action-bar","theme":"hello","animation":"slide","headline":"Get Access to ALL SDN Podcasts!","icon":"","message":"<p>Full Episodes &amp; VIP Access<\/p>\n","form_style":"style_0","form_layout":"bottom","form_bg_color":"","form_text_color":"","form_header":"","form_html_original":"","form_footer":"","label":"Subscribe Now","link":"https:\/\/www.dahl.com\/subscribe\/","bg_color":"#eb593c","text_color":"#000000","cta_bg_color":"","cta_text_color":"","position":"01","custom_css":"#ig_this_message .ig_headline{ \/* font-size: 3em !important; *\/ }","custom_js":"<script type=\"text\/javascript\"> \/* add your js code here *\/ <\/script>","id":"4841","delay_time":"45","retargeting":"yes","campaign_id":4840,"expiry_time":"current_session","retargeting_clicked":"yes","expiry_time_clicked":"today"}],"ajax_url":"http:\/\/www.dahl.com\/wp-admin\/admin-ajax.php","defaults":{"icon":"http:\/\/www.dahl.com\/wp-content\/plugins\/icegram\/assets\/images\/icegram-logo-branding-64-grey.png","powered_by_logo":"","powered_by_text":""},"scripts":["http:\/\/www.dahl.com\/wp-content\/plugins\/icegram\/assets\/js\/icegram.min.js?var=1.10.3"],"css":["http:\/\/www.dahl.com\/wp-content\/plugins\/icegram\/assets\/css\/frontend.min.css?var=1.10.3","http:\/\/www.dahl.com\/wp-content\/plugins\/icegram\/message-types\/action-bar\/themes\/action-bar.min.css?var=1.10.3"]};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dahl.com/wp-content/plugins/icegram/assets/js/main.min.js?ver=1.10.3'></script>
    <div class="secp-embed secp-embed-cart" data-shop="steve-dahl-network.myshopify.com" data-checkout_button_text="Checkout" data-button_text_color="ffffff" data-button_background_color="7db461" data-background_color="transparent" data-text_color="000000" data-accent_color="000000" data-cart_title="Your cart" data-sticky="true" data-embed_type="cart"></div>
    <script type="text/javascript"> document.getElementById('ShopifyEmbedScript') || document.write('<script type="text/javascript" src="https://widgets.shopifyapps.com/assets/widgets/embed/client.js" id="ShopifyEmbedScript"><\/script>'); </script><!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 3000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 10000 });
	jQuery('.g-3').gslider({ groupid: 3, speed: 3000 });
}
});
</script>
<!-- /AdRotate JS -->

<script type="text/javascript">
	(function($){
		$('.search-bar .submit').on( "click", function( event ) {
			var search_text = $('.search-bar .search.text').val();
			window.location.replace("/?s="+search_text);
		});

		$('.search-bar input').keypress(function(e) {
			if(e.which == 13) {
				var search_text = $('.search-bar .search.text').val();
				window.location.replace("/?s="+search_text);
			}
		});
	})(jQuery);
</script>
<script type="text/javascript">
	var addthis_config = {
		ui_click: true,
		ui_508_compliant: true,
		ui_use_css: false
	};
</script>
<script type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-52712ea95ec0152b"></script>


</body>
</html>
